digitall_it

also, make sure that when you run composer update, the CLI interpreter is the same version as the server one, or it can install the wrong packages.

digitall_it

yes, but you can put it where you want and change the row accordingly.

leggat

Should the logs directory be in the site root?

leggat

Ahh ok, I hadn't thought about the PHP versions, I will try both of those now. Thanks!

digitall_it

@leggat first and foremost, I suggest you to use PHP 7.1 if you can, it supports all the nice features that the cool kids use. Also, in you .env file put this row: SS_ERROR_LOG="logs/silverstripe_error.log" (don’t forget to create the logs directory if you don’t have it). It will help you troubleshoot the errors. Refresh and try again.

leggat

I think this is the bit I am struggling with

Files: Requires logging in with Slack to view/download
Pasted image at 2019-03-08, 4:04 PM
leggat

Hey I'm trying to get my head around SS4, coming from SS3 — I'm following this tutorial https://www.silverstripe.org/learn/lessons/v4/working-with-multiple-templates-1 , but when I load the homepage I get a server error. I think I might be doing something wrong with the 'namespacing'?

Show 1 attachment(s)
silverstripe.org  
SilverStripe Lessons » Working with Multiple Templates

Typically a site has more than one distinct template used across all pages. The home page, for instance, is likely to have a different layout than the “About Us” page or an image http://gallery.In|gallery.In this tutorial, we’ll introduce a custom template for the home page, and start cleaning up our project a bit by taking advantage of subtemplates and includes.

Hide attachment content
digitall_it

Strangely, sake works, but I cannot use it because I need to explicitly use the right php interpreter

digitall_it

@kinglozzer Thank you for answering me. I forgot to say that I already set it, to SS_BASE_URL="https://stage.casantonio.it"

kinglozzer

You probably need to set SS_BASE_URL in .env