wmk

Now I'm stuck on

> Unknown field 'parentUUID' on type 'SilverStripeDataObject'. SS4.4.4 / silverstripe-graphql 3.1.4

wmk

weird, the gatsby-source-silverstripe isn't installable with gatsby 2.17; had to require gatsby2.16

> error An unexpected error occurred: "could not find a copy of gatsby to link in D:\Users\<foo>\Documents\dev\<project>\site\docroot\gatsby\node_modules\gatsby-source-silverstripe\node_modules". is what I got before. Did I do anything wrong or are the module's settings a bit weird?

gened

I’ve used Formik forms + Apollo in Gatsby to great effect. You could also support more fields by stringifying your form data and decoding in SS via something like this

  1. mutation updateUserForm($id: Int!, $data: String) {
  2. updateUserForm(id: $id, data: $data) {
  3. successMessage
  4. }
  5. }
👌 (1)
unclecheese
  1. mutation {
  2. createComment(Input: { Comment: "foo", Email: "<mailto:[email protected]|[email protected]>", BlogEntryID: 5 }) {
  3. isSpam
  4. successMessage
  5. }
  6. }
wmk

ok. Render Form UI and send to REST instead?

unclecheese

Creating mutations and input types for forms is still a todo

unclecheese

The graphql form stuff will render the form UI, but it won’t yet handle the form for you.

wmk

So we could forward it to the SilverStripe blog module