blueskies

Yes, I have the preview disabled already (that's my default). I can fix the ones that jump to Untitled, but regular content editors cannot, and this really shouldn't happen. I just have a hard time tracing the source of the problem. The /edit/EditForm/ POST is correct, just somewhere along the way it becomes Title=Untitled (and it's not visible in the console/network)....

Firesphere

It's not ideal, but I've had a somewhat similar situation, where disabling the preview solved it for me, and knowing the ID and thus be able to change the URL manually helped a lot 🙂

Firesphere

Best thing I can say is disable the preview mode and keep track of the ID of the page 🙂

blueskies

I cannot, for the life of me, reproduce this... It happens out of the blue.... 😬

blueskies

I'm wondering if anyone has run into this issue before with SS4 (we also use Fluent and I kinda suspect that module as well): If I change and save multiple pages in the CMS (like today I changed the meta description of multiple pages, so open, copy/paste, save & publish, next).... Sometimes, out of the blue, the title of the page will change to Untitled (the URLSegment will be empty) and the CMS redirects me to the homepage... 🤪 I have a hard time clicking on the now untitled page (the cms keeps redirecting me), but if I open it and click "save&publish" quickly enough, I can access it again and change the Title back....

wmk

arraylist of strings won't work. You need to wrap the strings in objects, e.g. ArrayData

John Lombardo

Hmm... maybe that's not the problem... <% loop $excerpts %><p>$Me</p><% end_loop %> looks legit, right?

John Lombardo

Does that sound plausible, and is it possible to force it to insert the raw string?

John Lombardo

I have an ArrayList of strings. Some of those strings contain HTML tags. I think that is why when I attempt to insert them into my template in a loop it gives me Call to a member function XML_val() on string error.