dorsetdigital

Possibly.. although it says denied by server config, rather than a flat-out forbidden

nightjarnz

is it ... shared hosting?

mike_henden

Hi @nightjarnz, .htaccess (yes), running Apache (yes), shared hosting (no, it’s my local dev environment). Live site is running fine….

mike_henden

… plus other sites in local environment are OK

nightjarnz

and that they match a working site - e.g. permission on folder that holds the site, etc.

mike_henden

File permissions in CMS? Logged on as Admin I have full permissions according to this…

mike_henden

Yep, I can log in, I can see individual pages in CMS, I’m just forbidden from touching anything…

dorsetdigital

So the CMS is running, you can log in, but when you try and action, you get a 'Forbidden' toast pop-up?

mike_henden

Yep, you got it … although I can access the security section. Interesting?

dorsetdigital

If you look at the response in the browser dev tools, does it tell you anything? Is it a 403 status?

mike_henden

Yes, I have SS_ENVIRONMENT_TYPE='dev', Nothing else of note…

mike_henden

Hmm, now Apache is telling me:

  1. [Thu Nov 14 14:04:39 2019] [error] [client ::1] File does not exist: /Users/mikehenden/Sites/assets
dorsetdigital

Have you run a composer install and composer vendor-expose ?

dorsetdigital

Might be worth making sure everything is where it's supposed to be

mike_henden

Funny thing is Sites is where ALL my dev sites live. It’s not like I have a single SS install living there. And the others are working??

dorsetdigital

Yeah, but that error suggests that something is missing from the end of the URL. It shouldn't be trying to 'load' a directory. The webserver is denying that

dorsetdigital

Hence the error earlier (client denied by server configuration)

dorsetdigital

I'd run the commands, run a dev/build?flush and see if it makes any difference

dorsetdigital

Sounds like something screwy in the CMS, making oddball requests

mike_henden

Could it be anything to do with this?

  1. Source map error: Error: request failed with status 404
  2. Resource URL: http://localhost/Client_SS4.1.0/public/resources/vendor…/admin/thirdparty/bootstrap/js/dist/collapse.js?m=1532959962
  3. Source Map URL: collapse.js.map
  4.  
  5. Source map error: Error: request failed with status 404
  6. Resource URL: http://localhost/Client_SS4.1.0/public/resources/vendor…ripe/admin/thirdparty/bootstrap/js/dist/util.js?m=1532959962
  7. Source Map URL: util.js.map
dorsetdigital

Although those are just source maps, so shouldn't affect the operation

dorsetdigital

But, may be suffering from the same root cause as the actual problem

mike_henden

WTF??

  1. [Symfony\Component\Console\Exception\CommandNotFoundException]
  2. Command "vendor-expose" is not defined.

Sure I typed it right?!

mike_henden

Yes, navigated my way there first. composer install said there was nothing to update — composer vendor-expose then fell over…


Show less replies
Firesphere

Apache/Nginx does not have permission to read the files

✔️ (1)
mike_henden

Hey people, found and removed file — still getting error! No change on log…

nightjarnz

same thing you'd do with the ORM: $this->RelationshipName()->Field

nightjarnz

or if you wanna get really intense, RelationShipName.RelationShipName.RelationShipName.Field for example

nightjarnz

dot notation works like: RelationshipName.Field