View more context

 

Firesphere

Or, update the terminal to use PHP7.1 🙂

Normann

@Firesphere yes, SS3.7 is "announced" to compatible with php7.2, even the core, but just "announced" 🙂

Firesphere

Yeah, but a lot of modules aren't, so if you're not sure, php7.1 is the safe way to go for now

Normann

I think it is still a class but abstract class.

Scopey

It's renamed in SS3. Modules need to be updated to extend the new name. Then you can get backwards compatibility with if (!class_exists('Object') class_alias(...); in _config.php

dorsetdigital

It certainly installs on PHP7.2 with no issues (I just tested it)

nightjarnz

To be clear, the update to work on 7.2 is intended as an upgrade step - i.e. upgrade your server to run PHP 7 so you can safely update to SS4 (i.e. can test on the same environment).

nightjarnz

SS3 is in security patch only support now until end of life, so far as I understand.