View more context

 

dorsetdigital

What version of SS are you using? The later versions shouldn't have that issue in the ORM

MrBenn

Yes that did it, many thanks Tim!

dorsetdigital

With SQLSelect, you can use setSelect() to specify the columns

👍 (1)
Karina Gaulin

Is it difficult to upgrade an existing silverstripe project to the latest stable version?

dorsetdigital

Well, "difficult" is hard to define. It depends on where you're starting from, and what else is in the project (modules, custom code, etc.)

👍 (1)
dorsetdigital

An older SS4 to the latest SS4 is generally fairly straightforward

dorsetdigital

More recent SS3 to SS4 is OK, but some of the modules can be problematic sometimes

dorsetdigital

Essentially, the older the starting point, and the more complex the site... the more work will be involved