View more context

 

Mo

Hang on, does SS4 now require PHP 7.1 as a minimum?

Mo

Hmm, OK, I am just reading the server requirements page in the docs

Mo

I guess I should update my travis config to focus on PHP 7.1

Joe

@muskie9 looks like you’re right about the PHP requirement:

  1. • PHP 7.1+ (5.6+ was supported 4.0 - 4.4, we dropped support for these 6 months after PHP EOL'd them)
muskie9

that's gonna be a pain for clients that have maintenance contracts for minor/patch releases and host themselves 😬

Joe

yeah that’s us in a lot of cases (doing the hosting, that is)… lol

when we started doing SS4 sites, we deployed to a PHP7 server (thankfully), so no big deal for us

Mo

At least SS is pretty simple to port across servers

Mo

we have been pulling sites over to 7.1 from 5.6 and 7.0

muskie9

same here, usually pretty painless... some of our oldest sites are submodules... so between migrating servers and upgrades from SS3 to SS4 there are plenty of odd things to tackle lol

Mo

Someone did ask us about upgrading a 3.0 site to 4 last week...

muskie9

if it's all flat in the repo that'll be a bit tough, won't have any point of reference on module versions and what not... might be worth starting fresh with 4 and bringing things over as needed