View more context

 

Mo

Hmm, I have to ensure the 0 is a string, otherwise something converts it to null...

r3v3rb

ugh, latest update to 3.7.3 and FocusPoint module creates this: [User Warning] DataObject::__construct passed The value 'assets/HomePage/_resampled/CroppedFocusedImageWzIwMDAsMjAwMCwieCIsMjAwXQ/IMG-7608a.jpg'. It's supposed to be passed an array, taken straight from the database. Perhaps you should use DataList::create()->First(); instead? - any ideas?

Mansi

Hi, I have a ModelAdmin which manages a DataObject with a lot of fields displayed in summary_fields I need to add a horizontal scrollbar to be able to see the entire table.

Mansi

I've included following in a CSS file. which works fine on Chrome but not in IE. Any other suggestions?

Patrick Nelson

oh shit @r3v3rb I can't help you with your problem, but I'm happy to see this module exists 😄

Patrick Nelson

actually @r3v3rb I think a stack trace will definitely be needed if you can get one. are you sure it's an image that's being instantiated? I'm looking at SS v3.7 code and the Image class shouldn't be passing that. Is it possible that maybe you overrode the Image class with your own type that is right now (for some reason) not being instantiated and SS is auto-magically instantiating a generic DataObject in it's place or something? Since (unfortunately in SS 3.x) Image constructor does indeed take a file path string as the first param (this appears to change in SS 4.x where thankfully it starts to follow the standard of requiring an array containing the record values as the first param).