View more context

 

Michael

nvm, it looks like it’s a bug in the UI. It still shows draft over the image after pressing ‘apply changes’. You need to refresh the page to see that the image is published

Michael

An image upload field on a dataobject with no versioning. Uploading an image, and pressing ‘apply changes’ leaves the unpublished message on the image. Refreshing the page shows that the image is actually published

dorsetdigital

@nightjarnz I'm pretty sure there's an issue logged for it somewhere. @kinglozzer was talking about it some time ago I think

nightjarnz

There probably is. I ask because we're looking into this stuff at the moment, wondering what area of the CMS it is, as there are so many different facets to showing that kind of info.

nightjarnz

i.e. I'd like to make sure they're all covered :)

dorsetdigital

I've seen it in pretty much any upload field context. ModelAdmin, SiteConfig, pages, etc.

dorsetdigital

https://github.com/silverstripe/silverstripe-asset-admin/issues/960 just in case you need it

Show 1 attachment(s)
GitHub  
UploadField still displays “draft” label after a file has been published · Issue #960 · silverstripe/silverstripe-asset-admin

I’ve seen a few other people report this on Slack. For me, it‘s: A non-versioned DataObject with has_one => File::class private static $owns set up correctly Managed via a standard ModelAdmin in...

Hide attachment content
nightjarnz

UploadField, that was the info I was looking for :) Was wondering if it might a have been TinyMCE embed, or something else I hadn't considered.