View more context

 

Jerome Camacho

means if the one parent id on SiteTree is same on SiteTree_Live ?

Jerome Camacho

same also the status column if publish on SiteTree_Live , its also publish in SiteTree ?

Jerome Camacho

im trying to modify some records on parent id column on SiteTree about my issue on maximum execution

Jerome Camacho

i modify it and set the parent id same in SiteTree_Live and SiteTree

thats4shaw

Anyone have a nice way of updating the export fields on the member csv export without messing with the summary fields?

thats4shaw

Looking like extending SecurityAdmin and going in via the updateEditForm hook is the approach.

ShaneW

@thats4shaw in SS3 I did something like this:

  1. $exportColumns = $gridField->getConfig()->getComponentByType('GridFieldExportButton');
  2. $exportColumns->setExportColumns($tableColumns);

in a model admin, so just need to find the SS4 equivalent of that

thats4shaw

Yeah, ModelAdmin’s are slightly easier. Got it sorted easy enough with the approach mentioned above 🙂.

adrian

Anyone got any ideas for this issue: https://github.com/silverstripe/silverstripe-assets/issues/330 We’ve been facing it and can’t figure this one out

Show 1 attachment(s)
GitHub  
Multiple "Uploads" folders are being created · Issue #330 · silverstripe/silverstripe-assets

The issue At some point during normal CMS user activity new uploads folders are being created with the exact same name as prior ones. This poses a large issue as it fixing this means reconciling di...

Hide attachment content
thats4shaw

We kind of experienced something like this the other day where multiple folders were constantly being created and it would look like existing-folder-1, exisiting-folder-2 etc. The only thing I could pin it down to was a mismatching id in the File_Live table.

nightjarnz

@adrian Nothing to do with some kind of query filter interfering? (applied by e.g. fluent?)

nightjarnz

the other thing I would check, is Subsites.

nightjarnz

admins will see all folders, compare subsiteID if subsites is installed.

nightjarnz

Although 3 folders all for Canada (and no SubsiteID present) all seem to hint that this isn't the cause.

adrian

Not subsites, fluent seems weird. We’ve there is actually only the one record in File_Live and its for the original uploads folder.

Weirdly running:

  1. $folder = Folder::find_or_make('Uploads');
  2. $folder->publishSingle();

Will remove a folder record

adrian

SS4 site, been up for a year or so and has >50gb in assets with people editing them often

adrian

The annoying things is that there is no -v1 -v2 which would atleast make sense but somehow we’re bypassing onBeforeWrite or something 🙃

phyzical

i was asking due to the requirement for $owns

phyzical

which is what triggers the publish

mike.cole

We've had this problem on front end forms with file form fields. After migrating from ss3 to SS4.3^ it would create a duplicate of the folder the file is loaded into i.e. 2 x SecureUploads/consultations folders will appear (exact name/case but different IDs), after that all file uploads for that form will go to the new folder created. We haven't experienced this in CMS yet.

mike.cole

I can't say for certain, but we had the problem in 2.3 and still in 2.4, our tester never raised it before that. I think we went through all the releases before we went LIVE.

phyzical

so yeah does your Dataobject have $owns

phyzical

with a key that lines up with the relation name

phyzical

if not it might not be publishing , i could be wrong though

adrian

@mike.cole we’ve not been able to see how there could ever be a folder with the same name. Currently we’re opting to go down the route of creating a task that’ll run each day and fix the folder issue which is a lot less than ideal but without a ways forward it’ll have to do


Show less replies