View more context

 

theruss

@taoceanz sorry, I know this doesn't really help you per se 😞

taoceanz

It does help, @theruss This is part of an upgrade of a site that was using Translatable with two Locale. We have yaml files with translations for some things. As you noted, with Translatable creating multiple site trees, it was pretty straightforward to add just the required DOs to a page define what ever content in which ever language that was desired.

The way I see it, there's a few options via Fluent. 1) Widgets fields are localised which will allow multiple locales of content per single field on a single widget, 2) Widget objects are localised which will require code to display just widgets for the current locale when viewing in the CMS and on the public facing front-end, 3) Widget areas are localised which will display the contents of the given page per locale that's set, 4) Widgets and Widgets can't properly be translated per-se so require yaml translations.

theruss

Maybe ping @chillu or @tractorcow for more on the best way to go. Like I said, I haven't done anything with translated content since 2015 😛

theruss

Well if I really did then - "no worries" 🙂

will__

I've hit some problems trying to embed vimeo videos in SS4 content blocks. I get a 403 trying to add new videos.

will__

SS bug? or something else? Has anybody else seen this problem?

will__

Might be related to: https://github.com/silverstripe/silverstripe-framework/issues/9073

Show 1 attachment(s)
GitHub  
Embedded content throws 500 during connection issues. · Issue #9073 · silverstripe/silverstripe-framework

Affected Version 4.x + Description When using Embedded content on a web page (e.g. Homepage with embedded Youtube), if the connection to the 3rd party breaks, this throws an uncaught InvalidUrlExce...

Hide attachment content
will__

Just added a note about this on our basecamp, and the video embedded fine. So defo a SS issue