View more context

 

null

Try adding this to your project's composer.json? omnipay/common": "3.0.2 as 2.5.1"

wilr

hmm https://github.com/silverstripe/silverstripe-omnipay/blob/master/composer.json requires omnipay 3. Try check what version of core you’re using.

Show 1 attachment(s)
GitHub  
silverstripe/silverstripe-omnipay

SilverStripe integration with Omnipay PHP payments library. - silverstripe/silverstripe-omnipay

Hide attachment content
harvs1789uk

@wilr - I installed SilverShop using the one liner composer install shown on http://www.silvershop.io/download - composer require -d myshop "silvershop/core"

This is the versioning info for core:

  1. harvs:honesty-box-portal joeharvey$ composer show silvershop/core
  2. name : silvershop/core
  3. descrip. : Provides an ecommerce product catalog, shopping cart, and order management system
  4. keywords : ecommerce, online shopping, ordering, payment, shop, shopping cart, silverstripe
  5. versions : * dev-master, 3.x-dev
  6. type : silverstripe-vendormodule
  7.  
  8. requires
  9. silvershop/silverstripe-listsorter ^3@dev
  10. silvershop/silverstripe-sqlquerylist ^2@dev
  11. silverstripe/asset-admin *
  12. silverstripe/cms ^4
  13. silverstripe/silverstripe-omnipay ^3@dev
kinglozzer

@harvs1789uk We had a similar issue recently, IIRC we had to remove silverstripe-onmipay (or in your case silvershop), then add in the omnipay/common + omnipay/paypal requirements, composer update, then re-add the SilverStripe modules

harvs1789uk

and this is the output from composer for silverstripe-omnipay

  1. harvs:honesty-box-portal joeharvey$ composer show silverstripe/silverstripe-omnipay
  2. name : silverstripe/silverstripe-omnipay
  3. descrip. : SilverStripe Omnipay Payment Module
  4. keywords : omnipay, payment, silverstripe
  5. versions : * 3.0.0-alpha2
  6. type : silverstripe-vendormodule
  7.  
  8. requires
  9. omnipay/common ^2.4
  10. silverstripe/config ^1
  11. silverstripe/framework ^4
harvs1789uk

So seemingly core is including silverstripe-omnipay at version 3 or higher as expected, but that in tern is only including omnipay-common version 2.n not 3 as required by omnipay-paypal

kinglozzer

Basically what’s described here: https://github.com/silverstripe/silverstripe-omnipay/issues/212

Show 1 attachment(s)
GitHub  
Composer seems to install wrong version of omnipay/common · Issue #212 · silverstripe/silverstripe-omnipay

Installing silverstripe-omnipay per docs as follows: composer require silverstripe/silverstripe-omnipay ^[email protected] This installs the following: Package operations: 6 installs, 0 updates, 0 removals Ins...

Hide attachment content
harvs1789uk

Love how that seems like a legit issue, but the OP finds a solution/hack, so closes the ticket instead of having it resolved for others....lol

harvs1789uk

So @kinglozzer your work around was to uninstall silvershop and it's dependencies, install omnipay/common:3.0 and omnipay/paypal then reinstall silvershop/core and it's dependencies?