View more context



and this is the output from composer for silverstripe-omnipay

  1. harvs:honesty-box-portal joeharvey$ composer show silverstripe/silverstripe-omnipay
  2. name : silverstripe/silverstripe-omnipay
  3. descrip. : SilverStripe Omnipay Payment Module
  4. keywords : omnipay, payment, silverstripe
  5. versions : * 3.0.0-alpha2
  6. type : silverstripe-vendormodule
  8. requires
  9. omnipay/common ^2.4
  10. silverstripe/config ^1
  11. silverstripe/framework ^4

So seemingly core is including silverstripe-omnipay at version 3 or higher as expected, but that in tern is only including omnipay-common version 2.n not 3 as required by omnipay-paypal


Basically what’s described here:

Show 1 attachment(s)
Composer seems to install wrong version of omnipay/common · Issue #212 · silverstripe/silverstripe-omnipay

Installing silverstripe-omnipay per docs as follows: composer require silverstripe/silverstripe-omnipay ^[email protected] This installs the following: Package operations: 6 installs, 0 updates, 0 removals Ins...

Hide attachment content

Love how that seems like a legit issue, but the OP finds a solution/hack, so closes the ticket instead of having it resolved for


So @kinglozzer your work around was to uninstall silvershop and it's dependencies, install omnipay/common:3.0 and omnipay/paypal then reinstall silvershop/core and it's dependencies?


(we didn’t have silvershop, just silverstripe-omnipay, but I imagine it’s the same problem just a different cause)


@kinglozzer I reckon tagging 3.0.0 stable for omnipay is a good idea