View more context

 

Nightcrawler

I'll check the versioned snapshots, haven't used it yet. Thanks

Nightcrawler

Maybe one more thing about this topic, is it maybe possible to trigger/force the creation of a page version in the e.g. onAfterPublish event? That could be a workaround...at least on the Content Block pages.

jkersu

Anyone know how I can retrieve a DataObject that's been archived? Would I have to compare records in the _live and _versions table?

nightjarnz

@Nightcrawler that would end badly I'm pretty sure. Infinite loops, or unintentionally published content that shouldn't be live yet.

MichalKleiner

anyone experienced super slow elemental block publication? locally it takes 20s TTFB, but on the server it’s up to 40s (same db which is strange)… object is created quickly, the publication is slow, so checked the indexes, number of items in the db table (8k, not that much), so wondering if anyone seen something similar…

Nightcrawler

no external includes with e.g. file_get_contents anywhere? Just had something similar (not Elemental, just SS in general) where the other server timed out...

MichalKleiner

no, nothing like that in the code… surprising thing is the speed is slower in UAT/PROD than in local where the hw resources should be much more performant

MichalKleiner

I’ll ask the host provider to look into SQL logs and enable slow log as well

sutherlandesign

Just re-posting this again if anyone have solution. 🙂 Hello, does anyone know how to remove the 'Files' off the search results, only show the 'SiteTree' pages. I'm using SS4.4.4. I've tried this in the _config.php but getting 502 error:

  1. SilverStripe\ORM\Search\FulltextSearchable::enable(array('SiteTree'));

What's the right code for this or is there other way of doing this? Has anyone had the same issue i had?

jkersu

Does SiteTree have to be namespaced @sutherlandesign? So like SilverStripe\CMS\Model\SiteTree ?