View more context

 

mike_henden

Good afternoon people. Can anybody recommend a good, reliable image slider to use in SS4? Have always used Flexslider with SS3 versions but can’t get it to work properly in SS4. Slider works fine but I can’t include a link from a slide to the relevant page. Raised this issue on Flexslider Git Hub page early last month but there has been no response from the developers and I have no idea why Flexslider won’t play ball?!!

muskie9

hi @mike_henden, sorry for the delay on the tickets... we got slammed end of year, just wrapped up for the day w/project work and can help trouble shoot a bit

muskie9

just wanted to provide an update... I was able to track down the underlying issue with that button styling... we've also created a new repo (it's shea's linkable, but now not a fork that we'll maintain) allowing us to fix the issue... there's a new tag 4.1.0 for flexslider and be sure you're pulling in 1.0.1 for dynamic/silverstripe-linkable

let us know if you notice any additional issues with it or if other issues persist

mike_henden

Hey, thanks @muskie9, I’ll check this out. Yep, the linking was the only problem!

muskie9

👍 the unmaintained linkable module was on our list to figure out in any case, your ticket just got us there quicker 😉

muskie9

just a heads up you may have to zap shea's module manually from your vendor dir

mike_henden

Thanks for your help @muskie9, that sussed it! Have a great weekend!!

mike_henden

Now just wondering how I can turn the link into a ‘Learn More’ button… which mught have to wait until Monday… 🤔

muskie9

I'll have to check... I feel like we may implement something on top of this for our use cases to allow for various styles, but can't remember... otherwise from a text standpoint, the Title field I believe should allow for customizing it a bit... otherwise it'll just grab the title of the page linked to by default iirc


Show less replies
Admonish

If one (or more) of you Silverstripe guru's would take a peek at my question over on the #cms4 channel I would be most grateful.

CptPillow

Hi everyone. I am trying to add recaptcha to my php forms but dont seem to get it working with the way this form is built. any suggestions where it might need to go or if i am doing something wrong?

jkersu

Have a look at this maybe?https://stackoverflow.com/questions/41536338/add-google-recaptcha-on-a-silverstripe-form

It uses the following module to implement Recpatcha v2: https://github.com/UndefinedOffset/silverstripe-nocaptcha

Show 2 attachment(s)
UndefinedOffset/silverstripe-nocaptcha

A spam protector and form field using the new Google's reCAPTCHA 2 aka No Captcha.

UndefinedOffset/silverstripe-nocaptcha

A spam protector and form field using the new Google's reCAPTCHA 2 aka No Captcha.

Hide attachment content
👍 (1)
r3v3rb

Using CSVBulkLoader how can I create new related dataobject records whilst importing?

thats4shaw

Through relation callbacks. It’s a manual thing though.

r3v3rb

okay, so it is a manual process - just wanted to check

thats4shaw

Be a case of checking if one exists, if not make it and return it.