Ken Sander

Figured. Thanks! The docs for 4 just say PHP >=7.1 but figured it was the 7.4 issue.

Ken Sander

Just installed 4.4.4 in my dev setup with php 7.4 and getting this warning in the cms admin when running in dev mode.

: implode(): Passing glue string after array is deprecated. Swap the parameters in ..... vendor/silverstripe/framework/src/Forms/Form.php

This normal?

Ken Sander

Great. Thanks for the options. I’ll check the guide first

👍 (1)
Ken Sander

I’m definitely open to that as I’m running MAMP 4 and don’t want to pay upgrade to 5. I was actually googling earlier today for other options.

Ken Sander

So best method is to use homebrew and install php 7 and use PATH to point it there?

Ken Sander

Ya that makes sense. Using Catalina and updated the defautl shell to zsh. Must have removed it

Ken Sander

Just yesterday I updated a 4.0 site to 4.4.4 and it worked fine. But now on that same site if I run composer update, it gives that error.

Ken Sander

Why was I able to install numerous SS4 sites with this exact setup before then?

Ken Sander

The parse error I’m getting is not in the web browser, it’s in the terminal from running composer update