Chris

my desperate reach for input: can anyone help me with this question? https://stackoverflow.com/questions/59098141/silverstripe-formschema-with-submissions-and-validation

Show 1 attachment(s)
Stack Overflow  
Silverstripe - FormSchema with submissions and validation

I'm trying to make use of the new FormSchema class in Silverstripe 4 but I'm having a tough time with the workflow for submitting the form. I've been able to return the schema and state, but when

Hide attachment content
Chris

yeah i couldnt figure it out but the wildcard fixed it so I'm not complaining haha

(1)
Chris

@Mo thanks! That's essentially what I've done, but I wasn't using the wildcard in After. So it seems loading the routes after adminroutes but before something else was causing the issue

Chris

Well then...surprisingly After: '*' sorted it all out.

Chris

What would be the alternative for a framework only project? I'd like to return a 404 type response when users visit the base route.

Chris

yeah I've tried adding #graphqlroutes to After as well, I'm pretty stumped

Chris

Hey, I'm having an issue where adding After: #adminroutes in a custom routes.yml file is breaking the asset-admin module with errors: GET http://localhost:8080/admin/graphql/types 404 (Not Found) and GET http://localhost:8080/assets/admin.types.graphql 404 (Not Found). Removing #adminroutes fixes the error but breaks all admin routes because I'm overriding the base route (ie: '': 'My\Custom\Controller) -- framework v4.4.4