dorsetdigital

Probably. I expect we'll end up with a GBHTTP protocol, so we can take back control of our internet

(1) 😂 (1)
dorsetdigital

If you scroll to the bottom of the page, you can submit changes to the docs

💯 (1)
dorsetdigital

grumbles about the proliferation of bots being launched from Eastern Europe

dorsetdigital
  1. public function updateEditForm(Form $form)
  2. {
  3. $members = $form->Fields()->dataFieldByName('Members');
  4. $members->setList($members->getList()->sort('Surname'));
  5. $config = $members->getConfig();
  6.  
  7. $dataColumns = $config->getComponentByType('GridFieldDataColumns');
  8. $dataColumns->setDisplayFields([
  9. 'FirstName' => 'First Name',
  10. 'Surname' => 'Surname',
  11. 'Email' => 'Email',
  12. 'Company.CompanyName' => 'Company Name',
  13. 'IsActive.Nice' => 'Active',
  14. 'HelpdeskStatus' => 'Help Desk'
  15. ]);
  16.  
  17. }

Can someone remind me how to make the 'Help Desk' column searchable / filterable in Security Admin? getHelpdeskStatus() is a method added to Member via an extension. It displays properly, but I can't order or filter the gridfield using it 🤔

dorsetdigital

And in terms of checking the above... does the webserver user have (at least) read-permissions on the files?

mike_henden

Hi @dorsetdigital , I set this up last year but haven’t changed anything since… it’s on local dev environment. Is document root specified in .htaccess? And as far as I know webserver (MAMP) has full access ??>

Garry Yeatman

@mike_henden I've come across a few issues running SS in mamp. The issues mainly stem from the fact mamp runs apache.2.2 and most people are running 2.4. I hope that helps

Garry Yeatman

I've had issues with htaccess rules. I'd start by seeing if there is something actually in the htaccess causing your pain

mike_henden

thanks @Garry Yeatman, will investigate. Not sure if it is MAMP as it worked in MAMP a year ago and other sites are all OK??

Garry Yeatman

Hard to tell without actually digging in to your codebase 😄

But yeah, Those are pain points I've had with mamp previously.

dorsetdigital

The fact that you have a (mostly) working CMS tends to suggest that the config isn't too badly wrong

dorsetdigital

Have you just set this up? Is the document root pointing at the right place?

dorsetdigital

Possibly.. although it says denied by server config, rather than a flat-out forbidden