Hels

@Neil Creagh I can't remember the exact details but you can do this via yml file. If you search the slack archive website you should find the message where someone here told me how to do it!

Mo

I think if you did this via YML, it would be a global change?

Mo

In which case, looks like you can use GridFieldPaginator.default_items_per_page config variable

Mo

@Neil Creagh I just updated my answer with how to change this globally via YML

Neil Creagh

Great - thanks. Mo using ::class worked 👍


Show less replies
Hels

It doesn’t really explain what a “kit” is….

Hels

???? I don’t know. On their website the 2 options are “kits” or download

Hels

whats the best way to use font-awesome in templates in silverstripe? use the free “kits” thing or download the css?

Hels

I have a very strange problem. I have a domain name with several sub-domains all on cloudflare. 5 of the subdomains have .conf files on digital ocean. 2 of them (A and B) point the document root to their own silverstripe projects and work fine. 2 of them (C and D) point their document root to the same silverstripe project, and the fifth (E) points to a non-existent folder (was a silverstripe project before but was deleted). Visiting any of C,D, or E in Safari browser makes them all go to the silverstripe project belonging to B (chrome browser can’t find the DNS). I have also made another new subdomain on cloudflare but not made a .conf file for it and that also goes to the silverstripe project belonging to B. This never used to happen (site C used to work fine), plus previously I couldn’t have a sub-domain on cloudflare working without a .conf file or vice-versa

Anyone got any clues???

Hels

for the benefit of the archive: the issue was in the apache configuration. It automatically uses the .conf file in sites-enabled which is first in the alphabet as a “default” for any subdomain it doesn’t find a seperate .conf file for. Adding a aaa-default.conf file (aaa to be sure it will always be first in the alphabet) which just contains

  1. <VirtualHost _default_:80>
  2. Redirect 404 /
  3. </VirtualHost>

means that any unrecognised subdomains will just see a page saying error 404 page not found

Hels

@Jason Hale I remember seeing something about setting that in the regular Member class when I was recently reading it to try to figure out some stuff

👍 (1)
Hels

that .htaccess in public/assets I changed the owner to apache to allow flush to work normally. If I change the owner back to my login user will that allow the flush to work

Hels

its pages & pages of errors. but most of them seem to be about chmod() no permission

Hels

@nightjarnz your latest method did something but gave many errors. Ill see if I can figure tehm out

👍 (1)